A forum for owners of Yamaha TTR250 trail and enduro bikes!

Members Login
Post Info TOPIC: TTR250 was running fine, now only on choke and revving high (lean)


Member

Status: Offline
Posts: 12
Date:
TTR250 was running fine, now only on choke and revving high (lean)
Permalink  
 


My son finally got around to telling me the bike ”wont stay running”. Sure enough only runs on choke and when i was fiddling with throttle and choke while on ks, a partial donut fell out. (Try and post Pic) I was thinking exhaust pipe gasket @ cylinder but looked for images online and part looks like copper ring, this part is more red clay like material, and like an exhaust donut from automobile. Sound or look familiar to anyone?



Attachments
__________________


Super Guru

Status: Offline
Posts: 7315
Date:
Permalink  
 

A blocked pilot jet would give those symptoms and is a common issue especially when the bike has been laid up for a while.

The do-nut looks like it could be the remains of the shock bump stop?  New ones here. You are right that the exhaust gasket is a copper ring.

Brian



__________________

Exeter, Devon, UK

http://www.ttr250.com  - The one and only dedicated TTR250 FAQ! 
 

TIP: For easy viewing bookmark the "Recent Posts" view - http://ttr250.activeboard.com/p/recent/ 



Member

Status: Offline
Posts: 13
Date:
Permalink  
 

Mine was doing the same when I got it. Would only run at idle with choke or with the throttle cracked open a bit. If you are mechanically handy at all it's a pretty easy fix. I would recommend the All Balls carb rebuild kit from the TTR store. Follow the guide on this website. The only thing that I would add is that it's been my experience that boiling the carburetor in water and vinegar seems to clean out the pilot jet passages a bit better than just compressed air. I remove all the plastic bits before I do this just to be safe. While you have it apart check to make sure the accelerator pump is working as it seems to be common that they dry rot and fail. It won't affect idle but it will make the bike more fun to ride.



__________________


Member

Status: Offline
Posts: 12
Date:
Permalink  
 

Yeah when i got the bike carb was off, and in a coffee can with half the parts missing, had it running good after new airbox put on, was lean at first. He didnt ride the last couple months, i suppose this ethanol gas crapped her out. The funny thing is when it was running good the bike never revved this high on choke, i am thinking a compound problem but we will see. Got dark and i didnt look much besides confirming it wont stay running. I will clean the carb again and go from there. Might b askin more question, if not ill let yee know if somethin else or just gummed up. Thanks for pointing to low sppeed circuit for starters.



__________________


Member

Status: Offline
Posts: 13
Date:
TTR250 was running fine, now only on choke and reving high (lean)
Permalink  
 


Check if you have a air leak on the engine side intake boot. That can cause them to rev high on choke. That hose clamp needs to be tight tight.

__________________


Member

Status: Offline
Posts: 12
Date:
Permalink  
 

Will do, thanks. Workin 50 hr now till sun night, Monday i’ll be on it. Good luck



__________________


Member

Status: Offline
Posts: 21
Date:
Permalink  
 

I had a similar problem, and my cause was the small rubber sealing ring fitted to the choke plunger. It had come loose and was preventing the choke from sealing shut so essentially the bike was constantly running on choke and revving high at idle.

Pretty unlikely but worth a look?

__________________


Member

Status: Offline
Posts: 12
Date:
TTR250 was running fine, now only on choke and revving high (lean)
Permalink  
 


Good stuff, i will keep my eyes open when i get to the choke.



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard