A forum for owners of Yamaha TTR250 trail and enduro bikes!

Members Login
Post Info TOPIC: Speedo Stopped Working


Member

Status: Offline
Posts: 8
Date:
Speedo Stopped Working
Permalink  
 


Hi Guys

Halfway through my ride yesterday i noticed the speedo had stopped working I havent looked yet but suspect the cable. Its a blue 54 plate TTR with a analogue speedo.

Any ideas before i start pulling things apart!

Thanks

Ross

 



__________________
Moo


Senior Member

Status: Offline
Posts: 367
Date:
Permalink  
 

Almost definitely the washers and drive tab in the speedo by the wheel.

Its a washer with 3 prongs to it that drives the speedo round. When it gets dished, it no longer engages.

As a quick fix, whip it out and bash it flat.

In the long term, buy another drive tab washer

__________________

Malcolm, Northamptonshire. West Anglia TRF

1996 TTR 250 Raid

2005 TTR 250 Bluey



Super Guru

Status: Online
Posts: 7160
Date:
Permalink  
 

This thread may help wink



__________________

Exeter, Devon, UK

http://www.ttr250.com  - The one and only dedicated TTR250 FAQ! 
 

TIP: For easy viewing bookmark the "Recent Posts" view - http://ttr250.activeboard.com/p/recent/ 



Member

Status: Offline
Posts: 8
Date:
Permalink  
 

Brilliant!

Thanks guys i will have a look and order the bit required

Thanks again

Ross

__________________


Member

Status: Offline
Posts: 8
Date:
Permalink  
 

Just to say that i stripped it all down cleaned and regreased everything put a new tab washer plus the other two washers in and it all works fine now so thanks
I couldnt see anything obviously wrong with the original tab washer aside from looking a bit warn though!

Thanks Again

Ross

__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard